[Retroactivo] Problemas con traducciones en español
Incident Report for Rankmi
Postmortem

Actualmente en nuestra plataforma, tenemos archivos base que representan las traducciones para cada uno de los idiomas, en total 4 idiomas. Al momento de generarse una nueva traducción, se toma como base el idioma español y este se replica a cada uno de los archivos base de los demás idiomas, actualmente tenemos mas de 4000 traducciones para todos los procesos y todos los idiomas en Rankmi.

Para poder mantener las bases de traducciones actualizadas, en cada release de la APP, el API de traducciones recibe una solicitud para procesar y replicar las nuevas palabras que existan en las traducciones por defecto a toda la base de traducciones personalizadas. Debido a un bug presente en el código al momento de procesar las traducciones para el idioma español se agotaba el tiempo de espera por lo que las traducciones fallaban en ser sincronizadas.

El código ha sido corregido haciendo reingeniería del algoritmo que se encarga de realizar este proceso y el problema ya no está presente.

El alcance de este error no implica perdida de información para traducciones realizadas durante los últimos 5 días.

De todas maneras, durante las siguientes semanas continuaremos monitoreando la situación.

Posted Jul 15, 2019 - 16:55 GMT-04:00

Resolved
Hemos detectado problemas con las traducciones en español. La incidencia ya ha sido corregida.
Posted Jul 15, 2019 - 16:44 GMT-04:00
This incident affected: Traducciones.